About Student Virtual Lab (SVL)

Access to this service is only available to active Faculty and the students enrolled in designated course numbers requested by Faculty. Please contact DoIT-ServiceManagement@csulb.edu if you are interested in providing access for your students. Specific course section numbers are required to enable student access.

What is the Student Virtual Lab (SVL)?

This service provides 24 hour, 7 day a week access to university-licensed software used for classroom instruction and assignments. SVL offers no-cost, convenient access from nearly any common device to what would otherwise be expensive software. With SVL, students do not need to physically visit a campus computer lab.

Benefits:

  • No cost
  • Available 24 hours a day, 7 days a week (except during short periods of routine maintenance)
  • More consistent instructional experience since Mac and PC users will have a very similar virtual desktop environment
  • Compatible on most devices (Windows, Mac, iOS, Linux, and Android)
  • Up to 2 GB of temporary file storage on a semester-by-semester basis

Currently available software (as of Summer 2019):

  • ArcGIS
  • AutoCAD
  • Mathematica
  • Minitab
  • MATLAB
  • Python & Orange
  • R
  • RStudio
  • SAS
  • SPSS
  • Office 2016
  • Visual Studio Professional
  • Web Browsers (Internet Explorer and Google Chrome)

If you would like to utilize Student Virtual Lab (SVL) as part of your coursework, please feel free to utilize the verbiage below for your syllabi or course material:

To complete coursework, please navigate to https://svl.csulb.edu and log on to the Student Virtual Lab (SVL) using your BeachID credentials (CampusID and BeachID password). Select the applicable software package for your course. If you encounter problems or have questions, please contact the Technology Help Desk at 562-985-4959 or helpdesk@csulb.edu.

How do you access the Student Virtual Lab?

Visit https://svl.csulb.edu/

landing page and login options for Student Virtual Lab

Choosing the Right Option

You will have two options:

  1. Installing the software client on your device of choice, or
  2. Using the web browser (HTML) version.

The following details may help you decide which option may be best for you.

Options Pros and Cons
One-time installation of the client software (VMware Horizon Client) on your computer: Versions for Windows, Mac, iOS, Android, and Linux
Recommended if you are working on a personally owned computer.
Pro: Using the Horizon Client offers better performance and features. Con: Requires about 15 minutes for initial download and installation.
Web browser version (WMware Horizon HTML) Recommended if you will be working on a public/shared computer such as in a computer lab. Pro: Using the browser / HTML Access is the quickest method with nothing to install. Con: Performance and features may be noticeably lower than the full client install version

Option 1: One-time installation of the client software (VMware Horizon Client) on your device

This option will take approximately 15 minutes for the initial setup.

  • It is advisable to perform this installation while no other windows or documents are open because it may require a reboot to complete. Additionally, you must have administrative access to your computer in order to install the software (this shouldn't be a problem if it is your personally-owned device).
    1. Select the option to Install VMware Horizon Client. This is the option on the left in Figure 1 above.
    2. You will be taken to a web page to select the software version of the device on which you are installing the software. Make your selection and download the software. For Windows machines, it is advised to install the VMware Horizon Client for Windows (not the VMware Horizon Client for Windows 10 UWP).
    3. Once downloaded, Run the installation of the software through completion.
    4. After installation, open the software, which may be located as a shortcut on your desktop or in your program files. You may need to search for the “VMware Horizon Client.”
    5. After opening, you will need to double-click on “Add Server.”
    6. Enter the name of the Connection Server, which is https://svl.csulb.edu/ and click “Connect.”

      Adding a new server and connection server window
    7. Log in using the following login credentials as shown in Figure 3:
      • Username = your nine digit campus ID
      • Password = your Beach ID password
      • Note: be sure CAMPUS-DOMAIN is selected before logging in

        login window
    8. You will see available software, where you must make a selection.

      entering the virtual desktop environment pool of available software
    9. Important: After selecting your software for the first time, you should be presented with a Sharing dialog box. It will display a message asking if you want to share your removable storage and local files when using remote desktops and applications. It should detect the name of your computer, and click Allow. By doing this, you are enabling the ability to save files to your local files on your personal computer, rather than just within the virtual desktop environment.

      Removable storage and local files sharing dialog box

      If you are not presented with the Sharing prompt, you can go to Options and select Share Folders to select your local computer's mail file folders.

      Options to share folders
    10. Depending on which software application you selected, you can open the software by clicking on the desktop icon.

Option 2: Web browser version (WMware Horizon HTML)

Web browser

These are minimum supported browser versions to access SVL via the HTML/Web browser:

  • Chrome 57, 58
  • Internet Explorer 11
  • Safari 9, 10
  • Mobile Safari on iOS devices running iOS 9 or later
  • Firefox 52, 53
  • Microsoft Edge 38, 40

Operating systems

These are the supported operating systems to access SVL via the HTML/Web browser:

  • Windows 7 SPI (32- and 64-bit)
  • Windows 8x (32- and 64-bit)
  • Windows 10 (32- and 64-bit)
  • Mac OS X 10.11 (El Capitan)
  • Mac OS 10.12x (Sierra)
  • iOS 9
  • iOS 10
  • Chrome OS 28.x and later

Note: In many cases, the logon time may take up to one minute while the desktop image loads.

the web browser login box

  1. Log in using your BeachID login credentials:
    • Username = your nine-digit campus ID
    • Password = your BeachID password
    • Note: be sure CAMPUS-DOMAIN is selected before logging in
  2. Once you successfully log in, you will be presented with available software options. Depending on your assignment, choose the appropriate software. (This will launch you into a new virtual desktop environment which looks like Windows 10.)

    available virtual desktop software options
  3. Depending on which software you selected, you will see the software icon/shortcut on your desktop, in which case you will select and begin your assignment. It may take up to a minute for the software to open.

How-to Guides

Drag and Drop Files (client version only)

See article Student Virtual Lab (SVL) Notable Feature Upgrades.

Open Files (client version)

To open an existing file in any of the available software, simply open the software and go to the File menu. Select the option to Open. You should be presented with a drop-down list where you then select the local file folder on your physical computer.

Upload/Open Files (web browser version)

  1. Once your virtual desktop has loaded, click the left tab to open your options.

    desktop view showing the tab to open your virtual lab software options
  2. Select the second option to "Open File Transfer Panel" which will then show you options for uploading files. Options include: Drag and drop files into the window or clicking the "Choose Files" button to select files from your device's various drives or folders.

    showing the Transfer Files upload option

Saving Files (client version)

To save a file to your physical computer, while in your particular software application, simply go to the File menu. Select the option to Save. You should be presented with a drop-down list where you then select the local file folder on your physical computer in which to save the file.

Important details about saved files:

  • Saved files located on the virtual desktop or document folders are only retained on a semester-by-semester basis. Saved files are deleted two weeks after the last day of the semester. If you wish to save your files/work beyond the end of the semester, you are advised to save your files outside of the virtual desktop environment and on your physical computer or other external storage device.

Download Files (web browser version)

The steps are initially the same as Uploading. Select the second option to "Open File Transfer Panel" which will then show you options for uploading files. At this point, you will

  1. select the "Download" tab to select files that you have saved to your remote desktop session.
  2. Click "CTRL + c" to begin file transfer.
  3. After transfer, you will have the option to click a download icon to save file to your client machine (this is your personal device). Saving work to your personal device is recommended, since your saved files will be purged at the end of the semester.

    showing the Transfer Files download option

How to Print

Printing to a local printer is accomplished by first saving/downloading your document to your computer. See saving or downloading instructions. Once your document is saved to your device, you can print to printers that are available to you.

How to Print to campus UniPrint stations

The university offers printing services in the University Library and the Horn Center labs for a nominal fee. To do so, within the software application, select the print option to see the available print queues as shown in the figure X below:

  • Win32 Printer: Lab Color Printer
  • Win32 Printer: Lab BW Printer

    showing the available print queues within SPSS and other available applications

Once a printer is selected, you must enter the following information as shown in figure 9

  • A job name (this is to help identify your print job at the print release station)
  • Your first name (this is to help identify your print job at the print release station.
  • A password (create a password to secure it so other users cannot release your print job. It can be anything and is case sensitive.

Each Black & White print job is $0.10 per page and Color is $1.50 per page.

 Print job details input window

How to properly logout (fully installed VMware Horizon client)

Properly signing out of your virtual desktop session ensures that you free up limited sessions/licenses so that other students are able to use an available virtual desktop session. To logout properly:

  1. Under Options, select Disconnect and Log Off

    Options menu to disconnect and log off
  2. Then click the icon to disconnect from the server.

    screens showing software application pool available on the server

How to properly logout (web browser version)

Please logoff when done. If you do not properly logout, you will create an idle session. Idle sessions will expire after 60 minutes but idle sessions (open applications) will cause the session to become unstable or unusable.

  1. Click the Windows icon in the bottom-left corner.

    showing the Windows icon
  2. Select the Account icon (above the settings cog wheel)
  3. Select Sign out

    showing the Account icon and subsequent option to sign out
  4. After signing out, you will see the following VM Horizon window. Click the menu button to select Log out.

    showing option to log out from the VM Horizon menu
  5. Click OK to log off.

    Log off screen showing OK button to proceed

Maintenance

The Student Virtual Lab will undergo monthly maintenance during off peak morning hours (5 am to 8 am) on the third Thursday of each month, though no downtime is expected.

Known Issues

Web browser (html) version:

  • The SVL desktop window may appear too small on some browsers. It displays only partially and cannot be dragged to expand the size. In some cases, you can click the maximize button to maximize the screen. If this doesn't work, you may have to try using SVL in a different browser.
  • On Mac computers using Safari 10.1.2 you are able to upload file, but not download. You are advised to use a different browser (i.e., Firefox, Chrome) if you experience this.

"Failed to connect to the connection server" message:

  • Description: When accessing Student Virtual Lab (SVL) through the HTML Access portal using Chrome or Safari, users may observe an error “failed to connect to the connection server.”
  • Explanation: Safari and Chrome browsers have an "origin" request header in the HTTP POST. While other browsers, Internet Explorer and Firefox, do not. The default Horizon Access Point (AP) configuration file is not aware of all possible paths when there are multiple APs present. In our case, we have two. During application updates, the configuration file resets to a default setting, eliminating the manual entry of various AP names/paths resulting in an error, “failed to connect to the connection server.”
  • Workaround: If this occurs, use a different browser, i.e., Firefox (Mac/PC) or Internet Explorer (PC), until SVL administrator can edit the configuration file.

Contact for Help

For technical assistance, contact the Technology Help Desk at (562) 985-4959 or helpdesk@csulb.edu. See the Technology Help Desk page for location and hours.

Details

Article ID: 61031
Created
Wed 8/22/18 2:33 PM
Modified
Tue 8/13/19 2:56 PM